WordPress.org

Hakkında

Gereksinimler

Gereksinimler

WordPress’i çalıştırmak için barındırıcınızın şunları desteklemesi önerilir:

  • PHP 7.4 sürümü ya da üzeri.
  • MySQL 8.0 sürümü ya da üzeri YA DA MariaDB 10.5 sürümü ya da üzeri.
  • HTTPS desteği

Hepsi bu kadar. Apache veya Nginx WordPress’i çalıştırmak için en sağlam ve özellikli sunucu olarak önerilir, ancak PHP ve MySQL’i destekleyen herhangi bir sunucu da işinizi görecektir. Bununla birlikte, sitenizi kurarken ve çalıştırırken en sorunsuz deneyim için, hosting sayfasındaki her host yukarıdakileri ve daha fazlasını sorunsuz bir şekilde destekler.

Ayrıntılı PHP eklentisi önerileri için Barındırma Rehberi bölümüne bakabilirsiniz.

Not: Yalnızca eski PHP veya MySQL sürümlerine sahip olduğunuz eski bir ortamdaysanız WordPress, PHP 7.0+ ve MySQL 5.5.5+ ile de çalışır. Ancak, bu sürümler resmi Kullanım Ömrü Sonuna ulaşmıştır ve sitenizi güvenlik açıklarına maruz bırakabilir.

Barındırıcınızdan WordPress’i çalıştırmasını isteyin

Ev sahibinizin WordPress’i çalıştırıp çalıştıramayacağından emin değilseniz, işte onlara göndermek için kopyalayıp yapıştırabileceğiniz bir istek!

Açık kaynaklı WordPress <https://wordpress.org/> site yazılımını çalıştırmakla ilgileniyorum ve hesabımın aşağıdakileri destekleyip desteklemediğini merak ediyorum:

  • PHP 7.4 ya da üzeri
  • MySQL 8.0 ya da üzeri YA DA MariaDB 10.5 ya da üzeri
  • mod_rewrite modülü ile Nginx veya Apache
  • HTTPS desteği

Teşekkürler!

Zorunlu değildir ancak daha iyi güvenlik için önerilir

WordPress gibi PHP uygulamaları, sunucunun varsayılan paylaşılan kullanıcı adı yerine hesabınızın kullanıcı adını kullanarak çalıştırılırsa, barındırma güvenliği daha iyi olur. Barındırma hizmeti almayı düşündüğünüz hizmet sağlayıcıya, hesabınızın güvenliğini sağlamak için hangi önlemleri aldıklarını sorun.