Gereklilikler

To run WordPress we recommend your host supports:

  • PHP 7.2 sürümü ya da daha yükseği.
  • MySQL sürüm 5.6 veya daha büyüğü YA DA MariaDB sürüm 10.0 veya daha büyüğü.
  • HTTPS desteği

Gerçekten hepsi bu kadar. WordPress'i çalıştırmak için en sağlam ve en özellikli sunucu olarak Apache veya Nginx'i öneririz ancak PHP ve MySQL'i destekleyen herhangi bir sunucu bunu yapacaktır. Bununla birlikte, her olası ortamı test edemeyiz ve barındırma sayfamızdaki her sunucu yukarıdakileri ve daha fazlasını hiçbir sorun olmadan destekliyor.

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

Ask for it

Here’s a letter you can send to your host; copy and paste!

I’m interested in running the open-source WordPress <https://wordpress.org/> web software and I was wondering if my account supported the following:

  • PHP 7.2 veya daha üstü
  • MySQL 5.6 or greater OR MariaDB 10.0 or greater
  • Nginx or Apache with mod_rewrite module
  • HTTPS desteği

Teşekkürler!

Gerekli değil ancak daha iyi güvenlik için önerilir

Hosting is more secure when PHP applications, like WordPress, are run using your account’s username instead of the server’s default shared username. Ask your potential host what steps they take to ensure the security of your account.