Bu eklenti, WordPress’in son 3 ana dağıtımı ile test edilmemiş. Artık bakımı yapılmıyor veya desteklenmiyor olabilir ve WordPress’in daha güncel sürümleriyle birlikte kullanıldığında uyumluluk sorunları olabilir.

Region Detect

Açıklama

Region detect is a plugin for WordPress that detects the country that the current visitor is browsing from.

It can display the country to the user; something like: Hello visitor from Spain! or display a flag of the country. The plugin also makes the ISO 3166-1 country code and country name avaliable to other plugins.

Yükleme

  1. Extract the zip file and just drop the contents in the wp-content/plugins/ directory of your WordPress installation.
  2. Activate the plugin through the ‘Plugins’ page.
  3. Copy the MaxMind country database to the plugin folder, or add your MaxMind license key to the plugin admin panel.
  4. If you are using the web service enable caching and select the cache length that you need.
  5. Use %%COUNTRYCODE%% or %%COUNTRYNAME%% in your posts to display the two character country code or country name respectively.

SSS

Do I have to pay for the MaxMind database?

No, MaxMind offer a free version of the database. However the paid for version is more accurate.

I am a wordpress developer and want to access the country code or name in my code. How do I do that?

Easy 🙂 Just declare the global variables $rdISO3166_1 or $rdCountryName in your code and away you go.

İncelemeler

Bu eklenti için herhangi bir değerlendirme bulunmuyor.

Katkıda Bulunanlar ve Geliştiriciler

“Region Detect” açık kaynaklı yazılımdır. Aşağıdaki kişiler bu eklentiye katkıda bulunmuşlardır.

Katkıda bulunanlar

Değişiklik Kaydı

1.00.00

  • Initial version

1.01.00

  • Added option to set the country from the url

1.02.00

  • Corrected bug with the cache clearing too quickly
  • Added a table that shows countries and number of ip addresses that are cached

1.02.01

  • Corrected spelling mistakes

1.02.02

  • Removed debugging code

1.02.04

  • Fixed installation bug which was causing a crash when installing

1.02.05

  • Made plugin multisite compliant